歡迎光臨
每天分享高質量文章

Perlbrew 入門 | Linux 中國

用 Perlbrew 在你系統上安裝多個版本的 Perl。
— Ben Cotton


致謝
編譯自 | 
https://opensource.com/article/18/7/perlbrew
 
 作者 | Ben Cotton
 譯者 | geekpi ? ? 共計翻譯:764 篇 貢獻時間:1732 天

用 Perlbrew 在你系統上安裝多個版本的 Perl。

有比在系統上安裝了 Perl 更好的事情嗎?那就是在系統中安裝了多個版本的 Perl。使用 Perlbrew[1] 你可以做到這一點。但是為什麼呢,除了讓你包圍在 Perl 下之外,有什麼好處嗎?

簡短的回答是,不同版本的 Perl 是……不同的。程式 A 可能依賴於較新版本中不推薦使用的行為,而程式 B 需要去年無法使用的新功能。如果你安裝了多個版本的 Perl,則每個腳本都可以使用最適合它的版本。如果您是開發人員,這也會派上用場,你可以針對多個版本的 Perl 測試你的程式,這樣無論你的用戶運行什麼,你都知道它能否工作。

安裝 Perlbrew

另一個好處是 Perlbrew 會安裝 Perl 到用戶的家目錄。這意味著每個用戶都可以管理他們的 Perl 版本(以及相關的 CPAN 包),而無需與系統管理員聯繫。自助服務意味著為用戶提供更快的安裝,併為系統管理員提供更多時間來解決難題。

第一步是在你的系統上安裝 Perlbrew。許多 Linux 發行版已經在包倉庫中擁有它,因此你只需要 dnf install perlbrew(或者適用於你的發行版的命令)。你還可以使用 cpan App::perlbrew 從 CPAN 安裝 App::perlbrew 模塊。或者你可以在 install.perlbrew.pl[2] 下載並運行安裝腳本。

要開始使用 Perlbrew,請運行 perlbrew init

安裝新的 Perl 版本

假設你想嘗試最新的開發版本(撰寫本文時為 5.27.11)。首先,你需要安裝包:

  1. perlbrew install 5.27.11

切換 Perl 版本

現在你已經安裝了新版本,你可以將它用於該 shell:

  1. perlbrew use 5.27.11

或者你可以將其設置為你帳戶的預設 Perl 版本(假設你按照 perlbrew init 的輸出設置了你的配置檔案):

  1. perlbrew switch 5.27.11

運行單個腳本

你也可以用特定版本的 Perl 運行單個命令:

  1. perlberew exec 5.27.11 myscript.pl

或者,你可以針對所有已安裝的版本運行命令。如果你想針對各種版本運行測試,這尤其方便。在這種情況下,請指定版本為 perl

  1. plperlbrew exec perl myscriptpl

安裝 CPAN 模塊

如果你想安裝 CPAN 模塊,cpanm 包是一個易於使用的界面,可以很好地與 Perlbrew 一起使用。用下麵命令安裝它:

  1. perlbrew install-cpanm

然後,你可以使用 cpanm 命令安裝 CPAN 模塊:

  1. cpanm CGI::simple

但是等下,還有更多!

本文介紹了基本的 Perlbrew 用法。還有更多功能和選項可供選擇。從查看 perlbrew help 的輸出開始,或查看App::perlbrew 文件[3]。你還喜歡 Perlbrew 的其他什麼功能?讓我們在評論中知道。


via: https://opensource.com/article/18/7/perlbrew

作者:Ben Cotton[5] 選題:lujun9972 譯者:geekpi 校對:wxy

本文由 LCTT 原創編譯,Linux中國 榮譽推出

赞(0)

分享創造快樂